In short
- CVE-2022-25766 is a HIGH (CVSS 8.8) vulnerability affecting ungit (ungit project), ungit.
- Chance of exploitation in the next 30 days (EPSS): 34.5%, higher than 98.4% of all vulnerabilities.
- Fix: update to 1.5.20 or later.
| Package | Affected versions | Patched versions |
|---|
| ungit | < 1.5.20
| 1.5.20
|
| ungit npm | < 1.5.20
| 1.5.20
|
Description
The package ungit before 1.5.20 are vulnerable to Remote Code Execution (RCE) via argument injection. The issue occurs when calling the /api/fetch endpoint. User controlled values (remote and ref) are passed to the git fetch command. By injecting some git options it was possible to get arbitrary command execution.
NVD description
The package ungit before 1.5.20 are vulnerable to Remote Code Execution (RCE) via argument injection. The issue occurs when calling the /api/fetch endpoint. User controlled values (remote and ref) are passed to the git fetch command. By injecting some git options it was possible to get arbitrary command execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free