In short
- CVE-2022-25857 is a HIGH (CVSS 7.5) vulnerability affecting org.yaml:snakeyaml, snakeyaml (snakeyaml project).
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 87.1% of all vulnerabilities.
- Fix: update to 1.31 or later.
Description
The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.
NVD description
The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.
More vulnerabilities in org.yaml:snakeyaml
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free