In short
- CVE-2022-25882 is a HIGH (CVSS 7.5) vulnerability affecting onnx, onnx (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.9% of all vulnerabilities.
- Fix: update to 1.13.0 or later.
| Package | Affected versions | Patched versions |
|---|
| onnx PyPI | < 1.13.0
| 1.13.0
|
| onnx | < 1.13.0
| 1.13.0
|
Description
Versions of the package onnx before 1.13.0 are vulnerable to Directory Traversal as the external_data field of the tensor proto can have a path to the file which is outside the model current directory or user-provided directory, for example "../../../etc/passwd"
NVD description
Versions of the package onnx before 1.13.0 are vulnerable to Directory Traversal as the external_data field of the tensor proto can have a path to the file which is outside the model current directory or user-provided directory, for example "../../../etc/passwd"
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free