In short
- CVE-2022-25887 is a HIGH (CVSS 7.5) vulnerability affecting sanitize-html (apostrophecms), sanitize-html.
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.1% of all vulnerabilities.
- Fix: update to 2.7.1 or later.
Description
The package sanitize-html before 2.7.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure global regular expression replacement logic of HTML comment removal.
NVD description
The package sanitize-html before 2.7.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure global regular expression replacement logic of HTML comment removal.
More vulnerabilities in sanitize-html
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free