In short
- CVE-2022-25893 is a CRITICAL (CVSS 9.8) vulnerability affecting vm2 (vm2 project), vm2.
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.9% of all vulnerabilities.
- Fix: update to 3.9.10 or later.
| Package | Affected versions | Patched versions |
|---|
| vm2 | < 3.9.10
| 3.9.10
|
| vm2 npm | < 3.9.10
| 3.9.10
|
Description
The package vm2 before 3.9.10 is vulnerable to Arbitrary Code Execution due to the usage of prototype lookup for the WeakMap.prototype.set method. Exploiting this vulnerability leads to access to a host object and a sandbox compromise.
NVD description
The package vm2 before 3.9.10 are vulnerable to Arbitrary Code Execution due to the usage of prototype lookup for the WeakMap.prototype.set method. Exploiting this vulnerability leads to access to a host object and a sandbox compromise.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free