In short
- CVE-2022-25948 is a MEDIUM (CVSS 5.3) vulnerability affecting liquidjs (liquidjs), liquidjs.
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.0% of all vulnerabilities.
- Fix: update to 10.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| liquidjs | < 10.0.0
| 10.0.0
|
| liquidjs npm | < 10.0.0
| 10.0.0
|
Description
The package liquidjs before 10.0.0 is vulnerable to Information Exposure when ownPropertyOnly parameter is set to False, which results in leaking properties of a prototype. Workaround For versions 9.34.0 and higher, an option to disable this functionality is provided.
NVD description
The package liquidjs before 10.0.0 are vulnerable to Information Exposure when ownPropertyOnly parameter is set to False, which results in leaking properties of a prototype. Workaround For versions 9.34.0 and higher, an option to disable this functionality is provided.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free