In short
- CVE-2022-25967 is a HIGH (CVSS 8.8) vulnerability affecting eta (eta.js), eta.
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.8% of all vulnerabilities.
- Fix: update to 2.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| eta | < 2.0.0
| 2.0.0
|
| eta npm | < 2.0.0
| 2.0.0
|
Description
Versions of the package eta before 2.0.0 are vulnerable to Remote Code Execution (RCE) by overwriting template engine configuration variables with view options received from The Express render API. Note: This is exploitable only for users who are rendering templates with user-defined data.
NVD description
Versions of the package eta before 2.0.0 are vulnerable to Remote Code Execution (RCE) by overwriting template engine configuration variables with view options received from The Express render API.
**Note:** This is exploitable only for users who are rendering templates with user-defined data.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free