In short
- CVE-2022-26183 is a HIGH (CVSS 8.8) vulnerability affecting pnpm (pnpm), pnpm.
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.7% of all vulnerabilities.
- Fix: update to 6.15.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pnpm | < 6.15.1
| 6.15.1
|
| pnpm npm | < 6.15.1
| 6.15.1
|
Description
PNPM prior to v6.15.1 was discovered to contain an untrusted search path which causes the application to behave in unexpected ways when users execute PNPM commands in a directory containing malicious content. This vulnerability occurs when the application is ran on Windows OS.
NVD description
PNPM v6.15.1 and below was discovered to contain an untrusted search path which causes the application to behave in unexpected ways when users execute PNPM commands in a directory containing malicious content. This vulnerability occurs when the application is ran on Windows OS.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free