In short
- CVE-2022-26184 is a CRITICAL (CVSS 9.8) vulnerability affecting poetry, poetry (python-poetry).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 79.2% of all vulnerabilities.
- Fix: update to 1.1.9 or later.
| Package | Affected versions | Patched versions |
|---|
| poetry PyPI | < 1.1.9
| 1.1.9
|
| poetry | ≤ 1.1.9
| No fix yet |
Description
Poetry prior to v1.1.9 was discovered to contain an untrusted search path which causes the application to behave in unexpected ways when users execute Poetry commands in a directory containing malicious content. This vulnerability occurs when the application is ran on Windows OS.
NVD description
Poetry v1.1.9 and below was discovered to contain an untrusted search path which causes the application to behave in unexpected ways when users execute Poetry commands in a directory containing malicious content. This vulnerability occurs when the application is ran on Windows OS.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free