In short
- CVE-2022-28946 is a HIGH (CVSS 7.5) vulnerability affecting github.com/open-policy-agent/opa, open policy agent (openpolicyagent).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 64.1% of all vulnerabilities.
- Fix: update to 0.40.0 or later.
Description
An issue in the component ast/parser.go of Open Policy Agent v0.39.0 causes the application to incorrectly interpret every expression, causing a Denial of Service (DoS) via triggering out-of-range memory access.
NVD description
An issue in the component ast/parser.go of Open Policy Agent v0.39.0 causes the application to incorrectly interpret every expression, causing a Denial of Service (DoS) via triggering out-of-range memory access.
More vulnerabilities in github.com/open-policy-agent/opa
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free