In short
- CVE-2022-28948 is a HIGH (CVSS 7.5) vulnerability affecting gopkg.in/yaml.v3, yaml (yaml project).
- Chance of exploitation in the next 30 days (EPSS): 4.0%, higher than 90.5% of all vulnerabilities.
- Fix: update to 3.0.0-20220521103104-8f96da9f5d5e, 3.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| gopkg.in/yaml.v3 Go | < 3.0.0-20220521103104-8f96da9f5d5e< 3.0.1
| 3.0.0-20220521103104-8f96da9f5d5e3.0.1
|
| yaml | = 3.0.0
| No fix yet |
Description
An issue in the Unmarshal function in Go-Yaml v3 can cause a program to panic when attempting to deserialize invalid input.
NVD description
An issue in the Unmarshal function in Go-Yaml v3 causes the program to crash when attempting to deserialize invalid input.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free