In short
- CVE-2022-29546 is a HIGH (CVSS 7.5) vulnerability affecting net.sourceforge.htmlunit:neko-htmlunit, htmlunit (htmlunit).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 69.0% of all vulnerabilities.
- Fix: update to 2.61.0 or later.
Description
Impact
NekoHtml Parser suffers from a denial of service vulnerability on versions 2.60.0 and below. A specifically crafted input regarding the parsing of processing instructions leads to heap memory consumption. Please update to version 2.61.0.
For more information
If you have any questions or comments about this advisory:
NVD description
HtmlUnit NekoHtml Parser before 2.61.0 suffers from a denial of service vulnerability. Crafted input associated with the parsing of Processing Instruction (PI) data leads to heap memory consumption. This is similar to CVE-2022-28366 but affects a much later version of the product.
More vulnerabilities in net.sourceforge.htmlunit:neko-htmlunit
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free