In short
- CVE-2022-2986 is a HIGH (CVSS 8.8) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.47%, higher than 40.4% of all vulnerabilities.
- Fix: update to 3.11.9, 4.0.3 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.11, < 3.11.9≥ 4.0, < 4.0.3
| 3.11.94.0.3
|
| moodle | ≥ 3.11.0, < 3.11.9≥ 4.0.0, < 4.0.3
| 3.11.94.0.3
|
Description
Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk.
NVD description
Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free