In short
- CVE-2022-30284 is a CRITICAL (CVSS 9.8) vulnerability affecting python-libnmap, python-libnmap (python-libnmap project).
- Chance of exploitation in the next 30 days (EPSS): 5.6%, higher than 92.9% of all vulnerabilities.
- Fix: update to 0.7.3 or later.
Description
In the python-libnmap package through 0.7.2 for Python, remote command execution can occur (if used in a client application that does not validate arguments).
NVD description
In the python-libnmap package through 0.7.2 for Python, remote command execution can occur (if used in a client application that does not validate arguments). NOTE: the vendor believes it would be unrealistic for an application to call NmapProcess with arguments taken from input data that arrived over an untrusted network, and thus the CVSS score corresponds to an unrealistic use case. None of the NmapProcess documentation implies that this is an expected use case
More vulnerabilities in python-libnmap
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free