In short
- CVE-2022-30289 is a MEDIUM (CVSS 5.4) vulnerability affecting pycti, opencti (citeum).
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 44.3% of all vulnerabilities.
- Fix: update to 5.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pycti PyPI | < 5.3.0
| 5.3.0
|
| opencti | ≤ 5.2.4
| No fix yet |
Description
A stored Cross-site Scripting (XSS) vulnerability was identified in the Data Import functionality of OpenCTI through 5.2.4. An attacker can abuse the vulnerability to upload a malicious file that will then be executed by a victim when they open the file location.
NVD description
A stored Cross-site Scripting (XSS) vulnerability was identified in the Data Import functionality of OpenCTI through 5.2.4. An attacker can abuse the vulnerability to upload a malicious file that will then be executed by a victim when they open the file location.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free