In short
- CVE-2022-30290 is a HIGH (CVSS 7.5) vulnerability affecting pycti, opencti (citeum).
- Chance of exploitation in the next 30 days (EPSS): 0.98%, higher than 62.3% of all vulnerabilities.
- Fix: update to 5.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pycti PyPI | < 5.3.0
| 5.3.0
|
| opencti | ≤ 5.2.4
| No fix yet |
Description
In OpenCTI through 5.2.4, a broken access control vulnerability has been identified in the profile endpoint. An attacker can abuse the identified vulnerability in order to arbitrarily change their registered e-mail address as well as their API key, even though such action is not possible through the interface, legitimately.
NVD description
In OpenCTI through 5.2.4, a broken access control vulnerability has been identified in the profile endpoint. An attacker can abuse the identified vulnerability in order to arbitrarily change their registered e-mail address as well as their API key, even though such action is not possible through the interface, legitimately.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free