In short
- CVE-2022-30630 is a HIGH (CVSS 7.5) vulnerability affecting stdlib, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.4% of all vulnerabilities.
- Fix: update to 1.18.4, 1.17.12 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.18.0-0, < 1.18.4< 1.17.12
| 1.18.41.17.12
|
| go | ≥ 1.18.0, < 1.18.4< 1.17.12
| 1.18.41.17.12
|
Description
Calling Glob on a path which contains a large number of path separators can cause a panic due to stack exhaustion.
NVD description
Uncontrolled recursion in Glob in io/fs before Go 1.17.12 and Go 1.18.4 allows an attacker to cause a panic due to stack exhaustion via a path which contains a large number of path separators.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free