In short
- CVE-2022-31089 is a HIGH (CVSS 7.5) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.1% of all vulnerabilities.
- Fix: update to 5.2.3, 4.10.12 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 5.0.0, < 5.2.3< 4.10.12
| 5.2.34.10.12
|
| parse-server npm | ≥ 5.0.0, < 5.2.3< 4.10.12
| 5.2.34.10.12
|
Description
Impact
Certain types of invalid files requests are not handled properly and can crash the server. If you are running multiple Parse Server instances in a cluster, the availability impact may be low; if you are running Parse Server as a single instance without redundancy, the availability impact may be high.
Patches
To prevent this, invalid requests are now properly handled.
Workarounds
None
References
For more information
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In affected versions certain types of invalid files requests are not handled properly and can crash the server. If you are running multiple Parse Server instances in a cluster, the availability impact may be low; if you are running Parse Server as single instance without redundancy, the availability impact may be high. This issue has been addressed in versions 4.10.12 and 5.2.3. Users are advised to upgrade. There are no known workarounds for this issue.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free