In short
- CVE-2022-31112 is a HIGH (CVSS 8.2) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.2% of all vulnerabilities.
- Fix: update to 5.2.4, 4.10.13 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 5.0.0, < 5.2.4< 4.10.13
| 5.2.44.10.13
|
| parse-server npm | ≥ 5.0.0, < 5.2.4< 4.10.13
| 5.2.44.10.13
|
Description
Impact
Parse Server LiveQuery does not remove protected fields in classes, passing them to the client.
Patches
The LiveQueryController now removes protected fields from the client response.
Workarounds
Use Parse.Cloud.afterLiveQueryEvent to manually remove protected fields.
References
For more information
If you have any questions or comments about this advisory:
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In affected versions parse Server LiveQuery does not remove protected fields in classes, passing them to the client. The LiveQueryController now removes protected fields from the client response. Users are advised to upgrade. Users unable t upgrade should use `Parse.Cloud.afterLiveQueryEvent` to manually remove protected fields.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free