| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/hyperledger/fabric | ≥ 2.3.0, < 2.4.5< 2.2.7 | 2.4.52.2.7 |
| fabric | ≥ 2.3.0, < 2.4.5< 2.2.7 | 2.4.52.2.7 |
If a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. This fix checks for the malformed consensus request and returns an error to the consensus client.
github.com/hyperledger/fabric/orderer/common/cluster
Fixed in v2.2.7 and v2.4.5.
None, users must upgrade to v2.2.7 or v2.4.5.
https://github.com/hyperledger/fabric/releases/tag/v2.2.7 https://github.com/hyperledger/fabric/releases/tag/v2.4.5
If you have any questions or comments about this advisory:
Thank you to Haosheng Wang of OPPO ZIWU Security Lab for this disclosure.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free