In short
- CVE-2022-31158 is a HIGH (CVSS 7.5) vulnerability affecting packbackbooks/lti-1-3-php-library, lti 1.3 tool library (packback).
- Chance of exploitation in the next 30 days (EPSS): 0.86%, higher than 58.6% of all vulnerabilities.
- Fix: update to 5.0, 5.0.0 or later.
Description
Impact
Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request.
Patches
Users should upgrade to version 5.0 immediately
Workarounds
None.
NVD description
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
More vulnerabilities in packbackbooks/lti-1-3-php-library
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free