In short
- CVE-2022-31167 is a MEDIUM (CVSS 6.5) vulnerability affecting org.xwiki.platform:xwiki-platform-security, xwiki (xwiki).
- Chance of exploitation in the next 30 days (EPSS): 0.84%, higher than 57.9% of all vulnerabilities.
- Fix: update to 13.4.6, 13.10.1, 12.10.11 or later.
| Package | Affected versions | Patched versions |
|---|
| org.xwiki.platform:xwiki-platform-security Maven | ≥ 13.0, < 13.4.6≥ 13.10, < 13.10.1≥ 5.0, < 12.10.11
| 13.4.613.10.112.10.11
|
| xwiki | ≥ 13.0, < 13.4.6≥ 13.5, < 13.10.1≥ 5.0, < 12.10.11
| 13.4.613.10.112.10.11
|
Description
Impact
A bug in the security cache is storing rules associated to document Page1.Page2 and space Page1.Page2 in the same cache entry.
That means that it's possible to overwrite the rights of a space or a document by creating the page of the space with the same name and checking the right of the new one first so that they end up in the security cache and are used for the other too.
Patches
The problem has been patched in XWiki 12.10.11, 13.10.1, 13.4.6.
Workarounds
No workaround other than patching.
References
https://jira.xwiki.org/browse/XWIKI-14075
https://jira.xwiki.org/browse/XWIKI-18983
For more information
If you have any questions or comments about this advisory:
NVD description
XWiki Platform Security Parent POM contains the security APIs for XWiki Platform, a generic wiki platform. Starting with version 5.0 and prior to 12.10.11, 13.10.1, and 13.4.6, a bug in the security cache stores rules associated to document Page1.Page2 and space Page1.Page2 in the same cache entry. That means that it's possible to overwrite the rights of a space or a document by creating the page of the space with the same name and checking the right of the new one first so that they end up in the security cache and are used for the other too. The problem has been patched in XWiki 12.10.11, 13.10.1, and 13.4.6. There are no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free