In short
- CVE-2022-31177 is a LOW (CVSS 2.7) vulnerability affecting flask-appbuilder, flask-appbuilder (dpgaspar).
- Chance of exploitation in the next 30 days (EPSS): 0.77%, higher than 55.4% of all vulnerabilities.
- Fix: update to 4.1.3 or later.
Description
Impact
An authenticated Admin user could craft HTTP requests to filter users by their salted and hashed passwords strings. These filters could be made by using partial hashed password strings. The response would not include the hashed passwords, but an attacker could infer partial password hashes and their respective users.
Only when using AUTH_DB database authentication option.
Patches
Fixed on 4.1.3
For more information
If you have any questions or comments about this advisory:
NVD description
Flask-AppBuilder is an application development framework built on top of Flask python framework. In versions prior to 4.1.3 an authenticated Admin user could query other users by their salted and hashed passwords strings. These filters could be made by using partial hashed password strings. The response would not include the hashed passwords, but an attacker could infer partial password hashes and their respective users. This issue has been fixed in version 4.1.3. Users are advised to upgrade. There are no known workarounds for this issue.
More vulnerabilities in flask-appbuilder
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free