In short
- CVE-2022-31507 is a CRITICAL (CVSS 9.3) vulnerability affecting ganga, ganga (ganga project).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.3% of all vulnerabilities.
- Fix: update to 8.5.10 or later.
| Package | Affected versions | Patched versions |
|---|
| ganga PyPI | < 8.5.10
| 8.5.10
|
| ganga | < 8.5.10
| 8.5.10
|
Description
The ganga-devs/ganga repository before 8.5.10 on GitHub allows absolute path traversal because the Flask send_file function is used unsafely.
NVD description
The ganga-devs/ganga repository before 8.5.10 on GitHub allows absolute path traversal because the Flask send_file function is used unsafely.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free