In short
- CVE-2022-31799 is a CRITICAL (CVSS 9.8) vulnerability affecting bottle, bottle (bottlepy).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 82.1% of all vulnerabilities.
- Fix: update to 0.12.20 or later.
| Package | Affected versions | Patched versions |
|---|
| bottle PyPI | < 0.12.20
| 0.12.20
|
| bottle | < 0.12.20
| 0.12.20
|
Description
Bottle before 0.12.20 mishandles errors during early request binding.
NVD description
Bottle before 0.12.20 mishandles errors during early request binding.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free