In short
- CVE-2022-32189 is a HIGH (CVSS 7.5) vulnerability affecting stdlib, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.4% of all vulnerabilities.
- Fix: update to 1.18.5, 1.17.13 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.18.0-0, < 1.18.5< 1.17.13
| 1.18.51.17.13
|
| go | ≥ 1.18.0, < 1.18.5< 1.17.13
| 1.18.51.17.13
|
Description
Decoding big.Float and big.Rat types can panic if the encoded message is too short, potentially allowing a denial of service.
NVD description
A too-short encoded message can cause a panic in Float.GobDecode and Rat GobDecode in math/big in Go before 1.17.13 and 1.18.5, potentially allowing a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free