In short
- CVE-2022-33000 is a CRITICAL (CVSS 9.8) vulnerability affecting ml-scanner, ml-scanner (pypi).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.8% of all vulnerabilities.
- Fix: update to 0.1.7 or later.
| Package | Affected versions | Patched versions |
|---|
| ml-scanner PyPI | ≥ 0.1.0, < 0.1.7
| 0.1.7
|
| ml-scanner | ≥ 0.1.0, ≤ 0.1.5
| No fix yet |
Description
The ML-Scanner package in PyPI v0.1.0 to v0.1.5 was discovered to contain a code execution backdoor via the request package. This vulnerability allows attackers to access sensitive user information and digital currency keys, as well as escalate privileges.
NVD description
The ML-Scanner package in PyPI v0.1.0 to v0.1.5 was discovered to contain a code execution backdoor via the request package. This vulnerability allows attackers to access sensitive user information and digital currency keys, as well as escalate privileges.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free