In short
- CVE-2022-33127 is a CRITICAL (CVSS 9.8) vulnerability affecting diffy, diffy (diffy project).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 79.1% of all vulnerabilities.
- Fix: update to 3.4.1 or later.
| Package | Affected versions | Patched versions |
|---|
| diffy RubyGems | < 3.4.1
| 3.4.1
|
| diffy | = 3.4.1
| No fix yet |
Description
The function that calls the diff tool in versions of Diffy prior to 3.4.1 does not properly handle double quotes in a filename when run in a Windows environment. This allows attackers to execute arbitrary commands via a crafted string.
NVD description
The function that calls the diff tool in Diffy 3.4.1 does not properly handle double quotes in a filename when run in a windows environment. This allows attackers to execute arbitrary commands via a crafted string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free