In short
- CVE-2022-33879 is a LOW (CVSS 3.3) vulnerability affecting org.apache.tika:tika, tika (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 81.1% of all vulnerabilities.
- Fix: update to 2.4.1, 1.28.4 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.tika:tika Maven | ≥ 2.0.0, < 2.4.1< 1.28.4
| 2.4.11.28.4
|
| tika | ≥ 2.0.0, < 2.4.1< 1.28.4
| 2.4.11.28.4
|
Description
The initial fixes in CVE-2022-30126 and CVE-2022-30973 for regexes in the StandardsExtractingContentHandler were insufficient, and we found a separate, new regex DoS in a different regex in the StandardsExtractingContentHandler. These are now fixed in 1.28.4 and 2.4.1.
NVD description
The initial fixes in CVE-2022-30126 and CVE-2022-30973 for regexes in the StandardsExtractingContentHandler were insufficient, and we found a separate, new regex DoS in a different regex in the StandardsExtractingContentHandler. These are now fixed in 1.28.4 and 2.4.1.
More vulnerabilities in org.apache.tika:tika
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free