In short
- CVE-2022-34037 is a HIGH (CVSS 7.5) vulnerability affecting github.com/caddyserver/caddy, caddy (caddyserver).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.6% of all vulnerabilities.
- Fix: update to 2.5.2 or later.
Description
Withdrawn Advisory
This advisory has been withdrawn because it is a bug, not a vulnerability. According to the maintainer, the bug only affects the client side of the request and cannot cause a denial of service on the server.
Original Description
An out-of-bounds read in the rewrite function at /modules/caddyhttp/rewrite/rewrite.go in Caddy v2.5.1 allows attackers to cause a Denial of Service (DoS) on the client side via a crafted URI.
NVD description
An out-of-bounds read in the rewrite function at /modules/caddyhttp/rewrite/rewrite.go in Caddy v2.5.1 allows attackers to cause a Denial of Service (DoS) via a crafted URI. Note: This has been disputed as a bug, not a security vulnerability, in the Caddy web server that emerged when an administrator's bad configuration containing a malformed request URI caused the server to return an empty reply instead of a valid HTTP response to the client.
More vulnerabilities in github.com/caddyserver/caddy
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free