In short
- CVE-2022-34170 is a MEDIUM (CVSS 5.4) vulnerability affecting org.jenkins-ci.main:jenkins-core, jenkins (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.3% of all vulnerabilities.
- Fix: update to 2.332.4, 2.346.1, 2.356 or later.
| Package | Affected versions | Patched versions |
|---|
| org.jenkins-ci.main:jenkins-core Maven | ≥ 2.320, < 2.332.4≥ 2.346, < 2.346.1≥ 2.350, < 2.356
| 2.332.42.346.12.356
|
| jenkins | ≥ 2.320, ≤ 2.355≥ 2.332.1, ≤ 2.332.3
| No fix yet |
Description
Since Jenkins 2.320 and LTS 2.332.1, help icon tooltips no longer escape the feature name, effectively undoing the fix for SECURITY-1955.
This vulnerability is known to be exploitable by attackers with Job/Configure permission.
Jenkins 2.356, LTS 2.332.4 and LTS 2.346.1 addresses this vulnerability, the feature name in help icon tooltips is now escaped.
NVD description
In Jenkins 2.320 through 2.355 (both inclusive) and LTS 2.332.1 through LTS 2.332.3 (both inclusive) the help icon does not escape the feature name that is part of its tooltip, effectively undoing the fix for SECURITY-1955, resulting in a cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.
More vulnerabilities in org.jenkins-ci.main:jenkins-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free