In short
- CVE-2022-34749 is a HIGH (CVSS 7.5) vulnerability affecting mistune, mistune (mistune project).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 76.1% of all vulnerabilities.
- Fix: update to 2.0.3 or later.
| Package | Affected versions | Patched versions |
|---|
| mistune PyPI | ≥ 2.0.0a1, < 2.0.3
| 2.0.3
|
| mistune | ≤ 2.0.2
| No fix yet |
Description
In Mistune through 2.0.2, support of inline markup is implemented by using regular expressions that can involve a high amount of backtracking on certain edge cases. This behavior is commonly named catastrophic backtracking.
NVD description
In mistune through 2.0.2, support of inline markup is implemented by using regular expressions that can involve a high amount of backtracking on certain edge cases. This behavior is commonly named catastrophic backtracking.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free