In short
- CVE-2022-35204 is a MEDIUM (CVSS 4.3) vulnerability affecting vite (vitejs), vite.
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.3% of all vulnerabilities.
- Fix: update to 2.9.13, 3.0.0-beta.4 or later.
| Package | Affected versions | Patched versions |
|---|
| vite | < 2.9.13
| 2.9.13
|
| vite npm | ≥ 3.0.0-alpha.0, < 3.0.0-beta.4< 2.9.13
| 3.0.0-beta.42.9.13
|
Description
Vite before v2.9.13 was discovered to allow attackers to perform a directory traversal via a crafted URL to the victim's service.
NVD description
Vitejs Vite before v2.9.13 was discovered to allow attackers to perform a directory traversal via a crafted URL to the victim's service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free