In short
- CVE-2022-35410 is a HIGH (CVSS 7.5) vulnerability affecting mat2, mat2 (0xacab).
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.1% of all vulnerabilities.
- Fix: update to 0.13.0 or later.
| Package | Affected versions | Patched versions |
|---|
| mat2 PyPI | < 0.13.0
| 0.13.0
|
| mat2 | < 0.13.0
| 0.13.0
|
Description
mat2 (aka metadata anonymisation toolkit) before 0.13.0 allows ../ directory traversal during the ZIP archive cleaning process. This primarily affects mat2 web instances, in which clients could obtain sensitive information via a crafted archive.
NVD description
mat2 (aka metadata anonymisation toolkit) before 0.13.0 allows ../ directory traversal during the ZIP archive cleaning process. This primarily affects mat2 web instances, in which clients could obtain sensitive information via a crafted archive.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free