In short
- CVE-2022-36079 is a HIGH (CVSS 7.5) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.1% of all vulnerabilities.
- Fix: update to 5.2.5, 4.10.14 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 5.0.0, < 5.2.5< 4.10.14
| 5.2.54.10.14
|
| parse-server npm | ≥ 5.0.0, < 5.2.5< 4.10.14
| 5.2.54.10.14
|
Description
Impact
Internal fields (keys used internally by Parse Server, prefixed by _) and protected fields (user defined) can be used as query constraints. Internal and protected fields are removed by Parse Server from query results and are only returned to the client using a valid master key. However, using query constraints, these fields can be guessed by enumerating until Parse Server returns a response object.
Patches
The patch requires the master key to use internal and protected fields as query constraints.
Workarounds
Implement a Parse Cloud Trigger beforeFind and manually remove the query constraints, such as:
Parse.Cloud.beforeFind('TestObject', ({ query }) => {
for (const key in query._where || []) {
// Repeat logic for protected fields
if (key.charAt(0) === '_') {
delete query._where[key];
}
}
});
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Internal fields (keys used internally by Parse Server, prefixed by `_`) and protected fields (user defined) can be used as query constraints. Internal and protected fields are removed by Parse Server and are only returned to the client using a valid master key. However, using query constraints, these fields can be guessed by enumerating until Parse Server, prior to versions 4.10.14 or 5.2.5, returns a response object. The patch available in versions 4.10.14 and 5.2.5 requires the maser key to use internal and protected fields as query constraints. As a workaround, implement a Parse Cloud Trigger `beforeFind` and manually remove the query constraints.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free