In short
- CVE-2022-37601 is a CRITICAL (CVSS 9.8) vulnerability affecting loader-utils (webpack.js), loader-utils.
- Chance of exploitation in the next 30 days (EPSS): 3.5%, higher than 89.2% of all vulnerabilities.
- Fix: update to 2.0.3, 1.4.1 or later.
| Package | Affected versions | Patched versions |
|---|
| loader-utils | ≥ 2.0.0, < 2.0.3< 1.4.1
| 2.0.31.4.1
|
| loader-utils npm | ≥ 2.0.0, < 2.0.3< 1.4.1
| 2.0.31.4.1
|
Description
Prototype pollution vulnerability in function parseQuery in parseQuery.js in webpack loader-utils prior to version 2.0.3 via the name variable in parseQuery.js.
NVD description
Prototype pollution vulnerability in function parseQuery in parseQuery.js in webpack loader-utils via the name variable in parseQuery.js. This affects all versions prior to 1.4.1 and 2.0.3.
More vulnerabilities in loader-utils
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free