In short
- CVE-2022-40023 is a HIGH (CVSS 7.5) vulnerability affecting mako, mako (sqlalchemy).
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.5% of all vulnerabilities.
- Fix: update to 1.2.2 or later.
| Package | Affected versions | Patched versions |
|---|
| mako PyPI | < 1.2.2
| 1.2.2
|
| mako | < 1.2.2
| 1.2.2
|
Description
Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.
NVD description
Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free