In short
- CVE-2022-40149 is a HIGH (CVSS 7.5) vulnerability affecting org.codehaus.jettison:jettison, jettison (jettison project).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.0% of all vulnerabilities.
- Fix: update to 1.5.1 or later.
Description
Those using Jettison to parse untrusted XML or JSON data may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow. This effect may support a denial of service attack.
NVD description
Those using Jettison to parse untrusted XML or JSON data may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow. This effect may support a denial of service attack.
More vulnerabilities in org.codehaus.jettison:jettison
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free