In short
- CVE-2022-40314 is a CRITICAL (CVSS 9.8) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.7% of all vulnerabilities.
- Fix: update to 3.11.10, 4.0.4, 3.9.17 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.11, < 3.11.10≥ 4.0, < 4.0.4< 3.9.17
| 3.11.104.0.43.9.17
|
| moodle | ≥ 3.11, < 3.11.10≥ 3.9, < 3.9.17≥ 4.0, < 4.0.4
| 3.11.103.9.174.0.4
|
Description
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
NVD description
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free