In short
- CVE-2022-40604 is a HIGH (CVSS 7.5) vulnerability affecting apache-airflow, airflow (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.5% of all vulnerabilities.
- Fix: update to 2.4.0b1, 2.4.0rc1 or later.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 2.3.0, < 2.4.0b1≥ 2.3.0, < 2.4.0rc1
| 2.4.0b12.4.0rc1
|
| airflow | ≥ 2.3.0, ≤ 2.3.4
| No fix yet |
Description
In Apache Airflow 2.3.0 through 2.3.4, part of a url was unnecessarily formatted, allowing for possible information extraction.
NVD description
In Apache Airflow 2.3.0 through 2.3.4, part of a url was unnecessarily formatted, allowing for possible information extraction.
More vulnerabilities in apache-airflow
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free