In short
- CVE-2022-40899 is a HIGH (CVSS 7.5) vulnerability affecting future, python-future (pythoncharmers).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 80.1% of all vulnerabilities.
- Fix: update to 0.18.3 or later.
| Package | Affected versions | Patched versions |
|---|
| future PyPI | < 0.18.3
| 0.18.3
|
| python-future | ≤ 0.18.2
| No fix yet |
Description
An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted Set-Cookie header from malicious web server. This issue has been patched in version 0.18.3.
NVD description
An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted Set-Cookie header from malicious web server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free