| Package | Affected versions | Patched versions |
|---|---|---|
| squid | ≥ 2.5, < 5.7 | 5.7 |
A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free