In short
- CVE-2022-41777 is a HIGH (CVSS 7.5) vulnerability affecting nadesiko3 (kujirahand), nadesiko3.
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.9% of all vulnerabilities.
- Fix: update to 3.3.75 or later.
| Package | Affected versions | Patched versions |
|---|
| nadesiko3 | ≤ 3.3.74
| No fix yet |
| nadesiko3 npm | < 3.3.75
| 3.3.75
|
Description
Nako3edit is the editor component of Nadeshiko 3, a programming language developed based on Japanese. Improper check or handling of exceptional conditions in Nako3edit v3.3.74 and earlier allows a remote attacker to inject an invalid value to decodeURIComponent of nako3edit, which may lead the server to crash.
NVD description
Improper check or handling of exceptional conditions vulnerability in Nako3edit, editor component of nadesiko3 (PC Version) v3.3.74 and earlier allows a remote attacker to inject an invalid value to decodeURIComponent of nako3edit, which may lead the server to crash.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free