In short
- CVE-2022-41919 is a HIGH (CVSS 8.8) vulnerability affecting fastify (fastify), fastify.
- Chance of exploitation in the next 30 days (EPSS): 0.41%, higher than 35.2% of all vulnerabilities.
- Fix: update to 3.29.4, 4.10.2 or later.
| Package | Affected versions | Patched versions |
|---|
| fastify | ≥ 3.0.0, < 3.29.4≥ 4.0.0, < 4.10.2
| 3.29.44.10.2
|
| fastify npm | ≥ 3.0.0, < 3.29.4≥ 4.0.0, < 4.10.2
| 3.29.44.10.2
|
Description
Impact
The attacker can use the incorrect Content-Type to bypass the Pre-Flight checking of fetch. fetch() requests with Content-Type’s essence as "application/x-www-form-urlencoded", "multipart/form-data", or "text/plain", could potentially be used to invoke routes that only accepts application/json content type, thus bypassing any CORS protection, and therefore they could lead to a Cross-Site Request Forgery attack.
Patches
For 4.x users, please update to at least 4.10.2
For 3.x users, please update to at least 3.29.4
Workarounds
Implement Cross-Site Request Forgery protection using @fastify/csrf.
References
Check out the HackerOne report: https://hackerone.com/reports/1763832.
For more information
Fastify security policy
NVD description
Fastify is a web framework with minimal overhead and plugin architecture. The attacker can use the incorrect `Content-Type` to bypass the `Pre-Flight` checking of `fetch`. `fetch()` requests with Content-Type’s essence as "application/x-www-form-urlencoded", "multipart/form-data", or "text/plain", could potentially be used to invoke routes that only accepts `application/json` content type, thus bypassing any CORS protection, and therefore they could lead to a Cross-Site Request Forgery attack. This issue has been patched in version 4.10.2 and 3.29.4. As a workaround, implement Cross-Site Request Forgery protection using `@fastify/csrf'.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free