| Package | Affected versions | Patched versions |
|---|---|---|
| org.xwiki.platform:xwiki-platform-oldcore | ≥ 11.7RC1, < 13.10.7≥ 14.0.0, < 14.4.2 | 13.10.714.4.2 |
| xwiki | = 11.7= 14.4.3= 14.4.4> 11.7, < 13.10.7> 14.0.0, < 14.4.2 | 13.10.714.4.2 |
It's possible for a user with only Script rights to enable or disable a user: this operation should be only doable for users with admin rights.
This problem has been patched in XWiki 13.10.7, 14.4.2 and 14.5RC1.
There is no workaround other than upgrading the wiki, but note that this only impacts users with Script rights: administrator should take care which users have such right.
If you have any questions or comments about this advisory:
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free