In short
- CVE-2022-42735 is a HIGH (CVSS 8.8) vulnerability affecting org.apache.shenyu:shenyu-admin, shenyu (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.0% of all vulnerabilities.
- Fix: update to 2.5.1 or later.
Description
Improper Privilege Management vulnerability in Apache Software Foundation Apache ShenYu. ShenYu Admin allows low-privilege low-level administrators create users with higher privileges than their own. This issue affects Apache ShenYu: 2.5.0. Upgrade to Apache ShenYu 2.5.1 or apply patch https://github.com/apache/shenyu/pull/3958.
NVD description
Improper Privilege Management vulnerability in Apache Software Foundation Apache ShenYu.
ShenYu Admin allows low-privilege low-level administrators create users with higher privileges than their own.
This issue affects Apache ShenYu: 2.5.0.
Upgrade to Apache ShenYu 2.5.1 or apply patch https://github.com/apache/shenyu/pull/3958 https://github.com/apache/shenyu/pull/3958 .
More vulnerabilities in org.apache.shenyu:shenyu-admin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free