In short
- CVE-2022-42964 is a HIGH (CVSS 7.5) vulnerability affecting pymatgen.
- Chance of exploitation in the next 30 days (EPSS): 0.96%, higher than 61.6% of all vulnerabilities.
- Fix: update to 2025.10.7 or later.
| Package | Affected versions | Patched versions |
|---|
| pymatgen PyPI | ≤ 2022.9.21< 2025.10.7
| 2025.10.7
|
Description
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the pymatgen PyPI package, when an attacker is able to supply arbitrary input to the GaussianInput.from_string method.
NVD description
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the pymatgen PyPI package, when an attacker is able to supply arbitrary input to the GaussianInput.from_string method
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free