In short
- CVE-2022-42965 is a HIGH (CVSS 7.5) vulnerability affecting snowflake-connector-python, snowflake connector (snowflake).
- Chance of exploitation in the next 30 days (EPSS): 0.88%, higher than 59.1% of all vulnerabilities.
- Fix: update to 2.8.2 or later.
Description
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the snowflake-connector-python PyPI package, when an attacker is able to supply arbitrary input to the get_file_transfer_type method.
NVD description
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the snowflake-connector-python PyPI package, when an attacker is able to supply arbitrary input to the undocumented get_file_transfer_type method
More vulnerabilities in snowflake-connector-python
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free