In short
- CVE-2022-42966 is a HIGH (CVSS 7.5) vulnerability affecting cleo, cleo (python-poetry).
- Chance of exploitation in the next 30 days (EPSS): 0.99%, higher than 62.7% of all vulnerabilities.
- Fix: update to 2.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| cleo PyPI | ≥ 1.0.0a1, < 2.0.0< 2.0.0
| 2.0.0
|
| cleo | < 2.0.0
| 2.0.0
|
Description
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the cleo PyPI package, when an attacker is able to supply arbitrary input to the Table.set_rows method.
NVD description
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the cleo PyPI package, when an attacker is able to supply arbitrary input to the Table.set_rows method
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free