In short
- CVE-2022-43685 is a HIGH (CVSS 8.8) vulnerability affecting ckan, ckan (okfn).
- Chance of exploitation in the next 30 days (EPSS): 0.74%, higher than 54.8% of all vulnerabilities.
- Fix: update to 2.9.7, 2.8.12 or later.
| Package | Affected versions | Patched versions |
|---|
| ckan PyPI | < 2.9.7
| 2.9.7
|
| ckan | ≥ 2.9.0, < 2.9.7< 2.8.12
| 2.9.72.8.12
|
Description
CKAN through 2.9.6 account takeovers by unauthenticated users when an existing user id is sent via an HTTP POST request. This allows a user to take over an existing account including superuser accounts.
NVD description
CKAN through 2.9.6 account takeovers by unauthenticated users when an existing user id is sent via an HTTP POST request. This allows a user to take over an existing account including superuser accounts.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free